Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"Open Buddy List" not working
#1
Hello, it is as the title says. The "Open Buddy List" is not working. Upon inspecting element this is the error message I get:

Inspect Element Wrote:Failed to load https://www.lf-empire.de/forum/misc.php?...buddypopup: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'https://lf-empire.de' is therefore not allowed access.
[Image: random.php?pic=random]
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
The meaning of life is to give life a meaning.
Stop existing. Start living.
Reply
Thanks given by:
#2
*sigh...*

Which browser? Why is it so difficult to provide me with basic information?

Works for me in Firefox 57, @mfc confirmed that it works in Chrome.





Also, while I'm on a rant, go fix the certificate-error with HFE, your sig is bugging me.
For the record, the entire website is inaccessible for me (SSL_ERROR_BAD_CERT_DOMAIN, certificate is valid for *.alfahosting-server.de, alfahosting-server.de; not herofighter-empire.com).


edit: apparently, Firefox is super-sturdy in remembering sites where even hard refreshes (Ctrl+F5 or whatever) don't help. One gotta hit forget about this site to make it accessible.
Silverthorn
~ Breaking LFE since 2008 ~

"Freeze, you're under vrest!" - Mark, probably.

» Gallery | » Sprites | » DeviantArt
Reply
Thanks given by:
#3
It is working for me as well now. Thank you.

I will see what I can do about HFE.
[Image: random.php?pic=random]
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
The meaning of life is to give life a meaning.
Stop existing. Start living.
Reply
Thanks given by:
#4
Coming back to this topic, I've just noticed that this bug happens if the url has the www prefix.
[Image: random.php?pic=random]
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
The meaning of life is to give life a meaning.
Stop existing. Start living.
Reply
Thanks given by:
#5
Confirmed. Seems like it's got to do something with
{$mybb->settings['bburl']}
plus browsers being very picky about URLs nowadays. Gotta figure something out at some point, running a bit low on time right now...
Silverthorn
~ Breaking LFE since 2008 ~

"Freeze, you're under vrest!" - Mark, probably.

» Gallery | » Sprites | » DeviantArt
Reply
Thanks given by:
#6
I believe the easiest way is to just redirect www to non-www. This should also solve a few issues such as mirrored domain. Put this in the .htaccess inside the forum folder:

Code:
# Used to not interfere with the .htaccess from Joomla
RewriteEngine On
RewriteBase /

# HTTPS force
RewriteCond %{HTTPS} off
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

# Rewrite www to non-www
# Taken from: https://stackoverflow.com/questions/234723/generic-htaccess-redirect-www-to-non-www
RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ https://%1/forum/$1 [R=301,L]
[Image: random.php?pic=random]
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
The meaning of life is to give life a meaning.
Stop existing. Start living.
Reply
Thanks given by: Silverthorn
#7
Thanks! I added it now, please report back if you encounter any issues Wobble
Silverthorn
~ Breaking LFE since 2008 ~

"Freeze, you're under vrest!" - Mark, probably.

» Gallery | » Sprites | » DeviantArt
Reply
Thanks given by:




Users browsing this thread: 1 Guest(s)