Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Forum Upgrade
#1
One could think this is a (belated) April Fool's joke due to its unlikeliness but I'm currently in the middle of upgrading the forum software. Just as an info in case anything looks weird/is not working properly (or at all); will take a while until I get through all of it.

Once I get everything up and running again, I'll update this notice Wobble




Edit: as of now (May 13th), I can't seem to find any further issues that require fixes. Hence, I deem the forums as fully operational again! Join the wobble-party! WobbleWobbleWobbleWobbleWobbleWobble
Silverthorn
~ Breaking LFE since 2008 ~

"Freeze, you're under vrest!" - Mark, probably.

» Gallery | » Sprites | » DeviantArt
Reply
#2
So, the biggest bugs are taken care of by now. Naturally, there are a few things here and there that are odd (either in terms of behavior or design/styling). Please report anything you come across in this thread, I'll update this post accordingly. Thanks!




Known issues (d=design, B=bug, F=feature; strikethrough items are dealt with):
  • d: Editor-theme -> dark
  • F: Add DC code and spoiler-buttons to editor
  • B: Quick Reply reloads thread when you hit [Post Reply]
    (No idea how to fix so far, this issue is related to SCEditor; when it's disabled, everything is working properly, so it must be some javascript bugging)


  • B: Smilies are parsed in code which seems kind of silly
  • B: GMT/Local time doesn't alternate (bottom right of each page)
  • B: "Who was online lately" month-list is broken

  • B: Hide Thanks-bar when there isn't anybody thanking
  • B: Stop the redirect (i.e. page reload) when you hit the Thanks-button
    (having the feeling that this is also related to the editor --edit: it's not)

  • d: Proper icons for thanks

  • B: Forum Team is wonky
  • B: Reporting functionality is broken


Further issues
  • B: pagination number of pages was displayed as {1}
  • B: an SQL-query in a custom plugin was not sanitized properly, causing an SQL-error to appear
  • B: a level of spoilers is stripped everytime a post is parsed by the editor (e.g. hitting "preview post" removes not-nested spoiler-tags, preserving the content)
  • B: lost password retrieval not working (doesn't send out email when requesting the activation code)
Silverthorn
~ Breaking LFE since 2008 ~

"Freeze, you're under vrest!" - Mark, probably.

» Gallery | » Sprites | » DeviantArt
Reply
Thanks given by: MangaD
#3
Another bug is that the page reloads when hitting the Thanks button.

Silverthorn edited this post 05-12-2020 07:16 PM because:
fix'd!
[Image: random.php?pic=random]
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
The meaning of life is to give life a meaning.
Stop existing. Start living.
Reply
Thanks given by:
#4
"Preview Post" function removes the "Spoiler" tag.
(credits to Nyamaiku)

Silverthorn edited this post 05-17-2020 03:45 PM because:
Confirmed and (hopefully) patched out!
If it doesn't work, please do a hard refresh of the page.
[Image: uMSShyX.png]
~Spy_The_Man1993~
Steiner v3.00 (outdated), Challenge Stage v1.51
Luigi's Easier Data-Editor, A-Man's Sprite Mirrorer
Working on the LF2 Rebalance mod.
Avatar styled by: prince_freeza
Reply
Thanks given by: Silverthorn




Users browsing this thread: 2 Guest(s)